Problem with loadmatfile


My problem is that loadmatfile (maybe the full matio lib) does not work for me in Scilab2024.0.0 under MacOS Sonoma 14.2.1 M1 chip.
This is quite a significant problem, corrupting compatibility.
I got this error message:

An error has been detected while loading /Applications/ dlopen(/Applications/, 0x000A): tried: ‘/Applications/’ (no such file), ‘/System/Volumes/Preboot/Cryptexes/OS/Applications/’ (no such file), ‘/Applications/’ (no such file)

Could you help with this?


You are right, there has been a problem during the packaging as libmatio.11.dylib is missing in the application bundle. However, I think that just adding it manually won’t make macOS Gatekeeper very happy and you won’t be able to run Scilab any more. I will make a new bundle which will be available this afternoon, stay tuned.


The new bundle is available:

Can you test it (I already checked that loadmafile and savematfile work fine now).


Dear Stephane,

Thank you for your help, now it works wonderfully!


1 Like